• Willkommen im Forum „Tintenzirkel - das Fantasyautor:innenforum“.
 

Neue Beiträge und SSL

Begonnen von Maja, 25. Mai 2018, 02:21:33

« vorheriges - nächstes »

0 Mitglieder und 1 Gast betrachten dieses Thema.

Maja

Pünktlich zum 25. Mai habe ich das Forum von http auf https umgestellt, damit alles, was per Formular übermittelt wird, durch eine gesicherte Verbindung fließt. Das Zertifikat wird akzeptiert, es gibt nur ein Problem: Alles, was aus http-Quellen eingebunden wird, wird von den Browsern aus Sicherheitsgründen nicht mitgeladen.

Und das betrifft, leider, das Eingabefeld für die neuen Beiträge. Das ist nämlich in seiner üblichen Form Javascript-Basiert. Die dafür benötigten Scripte liegen hier auf dem Server, in einem Unterordner des Forums, und die Forensoftware bindet sie über http ein. Ich habe noch nicht herausgefunden, wie ich SMF sagen soll, dass diese Ordner bitte auch über https laufen. Ergebnis: Die Smileys und Formatierungsicons sind nicht da. Damit könnten wir zur Not leben, dann geben wir den Code dafür per Hand ein, kein Problem. Schlimmer ist, dass das Eingabefeld ungefähr so breit ist wie drei Bildschirme nebeneinander, und ich nicht sehe, wo ich das ändern sollte.

Im Moment gibt es also zwei Möglichkeiten:
- Ihr deaktiviert SSL, um Beiträge zu schreiben (klick auf das Schlosssymbol, Schutzmaßnahmen deaktiveren). Dann lädt das Javascript rein - aber die Daten werden nicht mehr verschlüsselt, womit der Sinn des Ganzen für den Allerwertesten ist
- Ihr beißt in den sauren Apfel und lebt mit dem unhandlichen, unübersichtlichen Eingabefeld.

Ich arbeite an einer Lösung. Aber ich habe auch eine unglaublich wichtige Verlagsdeadline im Nacken, die bis Ende des Monats absolute Priorität hat. Da das Forum grundsätzlich funktioniert (wenn auch mit Einschränkungen) und es nur um eine Woche geht, muss ich euch bitten, euch bis Juni zu gedulden. Wenn ich vorher etwas herausfinde, gebe ich Laut bzw. behebe das Problem sofort.
Niemand hantiert gern ungesichert mit kritischen Massen.
Robert Gernhardt

Maja

#1
Ich glaube, ich habe den Fehler gefunden. Es war nicht das Javascript, es war der Pfad zu den Smileys.

Wenn ihr Darstellungsprobleme habt oder andere Sachen nach der Umstellung auf https für euch nicht funktionieren, bitte gebt Bescheid.

Im Moment sehe ich die einzigen Meldungen "Seite ist unsicher" nur noch im Zusammenhang mit den Wordcountern. Am Schwarzen Brett im Thread zu den Signaturen habe ich bereits etwas dazu geschrieben. Wer dazu Fragen hat, darf sie gerne hier stellen - das Schwarze Brett selbst ist ja für alle außer Admins "Read Only"


EDIT
Habe für die Counter einen funktionierenden Workaround gefunden. Damit sollte jetzt das ganze Forum vollständig verschlüsselt funktionieren. Wenn euch irgendwo die Meldung "Verbindung ist nicht sicher" unterkommt, seid so lieb und meldet sie. Danke!
Niemand hantiert gern ungesichert mit kritischen Massen.
Robert Gernhardt

Tintenteufel

Ich denke ein ähnliches Problem hat sich auch für den Chat eingeschlichen.
Heute und gestern Abend(?) bin ich nicht reingekommen. Das Feld, wo üblicherweise Nickname usw. angegeben werden, war überhaupt nicht verfügbar, mich starrte eine weiße Seite an.
Erst das auflösen der sicheren SSL-Verbindung über den Browser hat das Feld und subsequent den Chat wieder sichtbar gemacht.
Vielleicht liegt es da auch an den Smileys?

Maja

#3
Argh! Der Chat! An den hab ich gar nicht gedacht. Ich glaube, der läuft noch komplett über http. Wird gleich behoben, ich melde mich!


EDIT
Tut es jetzt wieder?

EDIT2
Alles soweit wieder in Ordnung, verschüsselter Chat läuft.
Niemand hantiert gern ungesichert mit kritischen Massen.
Robert Gernhardt

Alana

#4
Ich habe leider das Problem, dass mein Handy (Android) mich seit der Umstellung auf SSL nicht mehr richtig ins Forum lässt, es sagt nämlich, dass das Zertifikat der Seite nicht sicher ist und Leute meine Daten stehlen könnten. Dieses Problem hatte ich vorher nicht und hatte es auch bisher auf keiner anderen Seite. Ich habe das Problem gelegentlich, wenn ich mich mit dem Handy über ein neues WLAN einlogge, aber das bezieht sich dann auf alle Seiten mit Zertifikat. Beim Zirkel ist es jetzt leider so, dass ich bei jeder neuen Unterseite des Zirkels, die ich aufrufe, erst zustimmen muss, dass ich trotz der Unsicherheit des Zertifikats weitersurfen will. Das macht es natürlich sehr ungemütlich. Vielleicht hat ja jemand einen Tipp, woran das liegen könnte? Außerdem habe ich auf dem Handy auch immer noch die ewig langen Eingabefelder. Ausloggen und wieder einloggen hat leider keines der beiden Probleme behoben. Ticker und Symbole werden mir auch nicht angezeigt.
Ich brauche jetzt kein Entenfett.

Maja

@Alana
Kannst du den Browsercache deines Handys leeren? Der Tintenzirkel hatte bis vor drei Tagen ein selbstsigniertes Zertifikat, das noch dazu letzten Dezember abgelaufen war, und es kann sein, dass dein Handy das noch irgendwo im Hintergrund gespeichert hat. Es war vorher nie relevant, aber seitdem alle Anfragen für Webseite und Forum auf https umgeleitet werden, ist das Zertifikat plötzlich relevant.

Das neue Zertifikat wurde durch eine gültige Zertifizierungsstelle ausgegeben. Ich muss es in drei Monatne verlängern, aber bis dahin ist es gültig. Ich vermute, du hast noch irgendwie das alte Zertifikat im Cache.
Niemand hantiert gern ungesichert mit kritischen Massen.
Robert Gernhardt

Alana

#6
So scheint es zu klappen. Smileys, Counter etc. sehe ich allerdings nicht und das lange Eingabefeld ist immer noch da.

Edit: Jetzt ist alles prima, auch das Eingabefeld ist wieder normal. Danke!

Edit 2: Jetzt ist es wieder da. Bei jedem Klick muss ich erlauben, dass mein Handy die Sicherheitswarnung ignoriert.
Ich brauche jetzt kein Entenfett.

HauntingWitch

Habe das gleiche Problem, falls die Information hilfreich ist. Aber kein Stress.

Maja

Benutzt die die Mobile Skin oder das klassische Tintenzirkel-Design?
Niemand hantiert gern ungesichert mit kritischen Massen.
Robert Gernhardt

Akirai

Ich nutze normalerweise das Klassische (aber wenn ich die Seite aufrufe, kommt bereits die Warnung, dass der Tintenzirkel keine sichere Seite sei. Ich gehe trotzdem drauf  ;) )

Maja

Aber sehe ich das richtig, dass das Problem nur auf Mobilgeräten auftritt? Welche App benutzt ihr zum Browsen?
Niemand hantiert gern ungesichert mit kritischen Massen.
Robert Gernhardt

Nycra

Da ich das Problem auch habe: Ich benutze sowohl die Samsung Internet-App als auch Chrome, funktioniert bei beidem trotz Cacheleeen nur aktuell, sobald man raus und wieder reingeht, besteht das Problem mit der unsicheren Seite wieder. Die vergrößerte Anzeige und das Smiley-Problem besteht zudem generell.

HauntingWitch

Ich nutze immer die klassische Ansicht mit Samsung Internet-App. Gestern hat es mal ein paar Stunden lang funktioniert und dann plötzlich wieder nicht. Habe es als Startseite, sehe es also immer, wenn ich den Browser öffne.

Alana

Bei mir nur mit dem Mobilgerät auf allen Browsern (Chrome und Samsung Internet) und egal ob WLAN oder mobiles Datennetz. Ich benutze die klassische Ansicht.
Ich brauche jetzt kein Entenfett.

Steffi

Ich habe auf dem Handy dasselbe Problem: Bei jeder Unterseite, die ich aufrufe, muss ich erst bestätigen, dass diese angeblich unsichere Seite besuchen will. Ich benutze auch das Samsung Internet und die klassische Ansicht des Tintenzirkels.
Sic parvis magna