• Willkommen im Forum „Tintenzirkel - das Fantasyautor:innenforum“.
 

Wechsel der PHP-Version möglich?

Begonnen von Feuertraum, 27. Juli 2018, 10:24:32

« vorheriges - nächstes »

0 Mitglieder und 1 Gast betrachten dieses Thema.

Feuertraum

Einen wunderschönen Guten Morgen,

sorry, dass ich schon wieder mit einer Webdesignfrage nerve:

Ich befürchte zwar, dass die Profis unter Ihnen jetzt entweder die Augen verdrehen oder die Haare raufen obgleich meiner "dummen" Frage, aber ich hoffe, Sie können mir dennoch helfen.

Ich habe auf meinem Webspace (kein kostenloser) sowohl ein Forum als auch eine friendica-Instanz laufen, die beide mit der voreingestellten PHP-Version 5.6.33 by OS Vendor - PHP ausführen als FastCGI-Anwendung von Apache bedient (das sind zumindest die Angaben, die ich bei der PLESK-Oberfläche gefunden habe) stabil laufen.

Dann wollte ich gestern noch ein anderes Programm aufspielen (GNU/Social), was aber bei der Installation zu folgender Fehlermeldung führte:

ZitatCannot load required extension:
|intl|
Please fix the above stated problems and refresh this page to continue
installing.

Eine Anfrage bei meinem Webspaceanbieter ergab, dass dieses Problem damit gelöst wird, dass man auf PHP-Version 7 wechselt.
Geht das einfach so, dass ich schlichtweg auf der PLESK-Oberfläche von der 5.6.33 auf eine PHP 7-Version wechsele (sprich dieses im DropDownmenue einstelle) oder laufe ich damit Gefahr, dass die beiden anderen Programme (Forum und friendica-Instanz) damit plötzlich nicht mehr funktionieren?

Für die Antworten bedanke ich mich im Voraus

LG
Feuertraum

Ich habe meine Schachuhr wiedergefunden :-) Nur: Wie stelle ich das Ding um von Sommer- auf Winterzeit?

Eluin

Es kann passieren, dass dadurch die anderen anderen Programme nicht mehr laufen. Das Problem bei Versionswechseln ist, dass eben auch alte Funktionen nicht mehr existieren könnten. Und dadurch kann es passieren, dass die anderen Programme nicht mehr laufen. Du könntest es ausprobieren und wenn dir alles um die Ohren fliegt die PHP-Version wieder runterstellen. Grundsätzlich tendiere ich aber zu neueren Versionen (Sicherheitslücken usw.). Kannst du von den anderen Programmen neuere Versionen einspielen?
Träume verändern die Zukunft. Doch erst wenn wir die Augen öffnen, können wir sie verwirklichen!
Mein Spruch, mein Motto.

Feuertraum

Heiho,

erst einmal Danke für die Antwort. Ich habe es dahingehend probiert, dass ich bei meinem Webspaceanbieter, auf dem mein Forum gehostet ist, die höchste verfügbare Version eingestellt habe und dann immer eine Version runter, bis keine Fehlermeldung angezeigt wurde. Das war bei der 7.1.20 der Fall.

Zitat von: EluinGrundsätzlich tendiere ich aber zu neueren Versionen (Sicherheitslücken usw.). Kannst du von den anderen Programmen neuere Versionen einspielen?

Prinzipiell könnte ich das, aber ...
Ich nutze eine Forensoftware, die Geld kostet (auch wenn der eine oder andere nur den Kopf schütteln kann, aber ich empfinde die Features dieser Software einfach besser als die Features anderer Forensoftware, aber dass ist sicherlich Geschmacks- und Ansichtssache.)
Wenn ich mir die neueste Version zulegen würde wollen, kommt mich das Ganze 90 € und 50 € für den Kalender und knapp 20 € für das Lexikon (ich rechne jetzt erst einmal alles Neupreis). Im Groben und Ganzen also 160 €.
Prinzipiell eine Geschichte, die ich gerne zu bezahlen bereit bin, WENN die Community groß genug dafür ist, und damit meine ich schon einen aktiven, vierstelligen Mitgliederbereich. Doch solange das nicht gegeben ist UHUND meine Version ohne Probleme stabil läuft und so funktioniert, wie sie funktionieren soll, sehe ich ehrlich gesagt keinen Grund, jetzt schon das Geld dafür rauszuschmeissen.

Auf alle Fälle habe ich dank der höheren PHP-Version jetzt die Möglichkeit, GNU/Social zu installieren.  :D

LG
Feuertraum
Ich habe meine Schachuhr wiedergefunden :-) Nur: Wie stelle ich das Ding um von Sommer- auf Winterzeit?

Eluin

Zitat von: Feuertraum am 30. Juli 2018, 17:05:40
Auf alle Fälle habe ich dank der höheren PHP-Version jetzt die Möglichkeit, GNU/Social zu installieren.  :D
Super! So soll es sein.

Und keine Angst, ich schüttle nicht den Kopf. Es gibt durchaus einige Dinge, wofür ich bereit bin Geld auszugeben.
Träume verändern die Zukunft. Doch erst wenn wir die Augen öffnen, können wir sie verwirklichen!
Mein Spruch, mein Motto.